Ten błąd pojawia się w pliku dziennika konektora Rublon MFA dla RD Gateway, gdy metody uwierzytelniania zdefiniowane w opcji authenticationMethods nie są zgodne z konfiguracją w konsoli Rublon Admin Console lub z metodami zarejestrowanymi przez użytkownika.
Możliwe przyczyny
Błąd “Please make sure that methods configured in the registry are enabled in the Rublon Admin Console, and given user has also them available” jest wyświetlany w pliku dziennika konektora Rublon MFA dla RD Gateway w następujących przypadkach:
• Metody wymienione w opcji authenticationMethods w rejestrze systemu Windows nie są włączone w konsoli Rublon Admin Console. Na przykład: Opcja authenticationMethods została zdefiniowana jako push,email, ale aplikacja typu Remote Desktop Gateway zdefiniowana w zakładce Applications (Aplikacje) konsoli Rublon Admin Console ma przypisaną politykę Custom Policy (Politykę niestandardową), którą deaktywuje te dwie metody uwierzytelniania.
• Żadna z metod zdefiniowanych w opcji authenticationMethods nie jest zarejestrowana na koncie danego użytkownika
Rozwiązanie
1. Zaloguj się do konsoli Rublon Admin Console.
2. Sprawdź, czy metody uwierzytelniania zdefiniowane w opcji authenticationMethods są włączone w aplikacji typu Remote Desktop Gateway zdefiniowanej w zakładce Applications (Aplikacje) konsoli administracyjnej. Zwróć uwagę na przypisane polityki.
3. Upewnij się, że każdy użytkownik, którego dotyczy problem, ma zarejestrowaną co najmniej jedną z tych metod. Użytkownik nie będzie mógł się zalogować jeśli nie zarejestrował żadnej z metod zdefiniowanych w opcji authenticationMethods. W takim przypadku wyślij mu E-mail rejestracyjny wraz z instrukcjami dotyczącymi rejestracji uwierzytelniaczy.
Najlepsze praktyki
• Zawsze dbaj o spójność konfiguracji konsoli administracyjnej z ustawieniami rejestru.
• Zawsze sprawdzaj status rejestracji użytkownika podczas rozwiązywania problemów z logowaniem.
Pomocne linki
Rublon MFA dla Remote Desktop Gateway - Dokumentacja
Czy ten artykuł był pomocny?
To wspaniale!
Dziękujemy za opinię
Przepraszamy, że nie udało nam się pomóc!
Dziękujemy za opinię
Wysłano opinię
Doceniamy Twój wysiłek i postaramy się naprawić artykuł