This error appears in Rublon MFA for RD Gateway logs when authentication methods defined in authenticationMethods are not properly aligned with the configuration in the Rublon Admin Console or with the user's enrolled methods.
Possible Causes
The “Please make sure that methods configured in the registry are enabled in the Rublon Admin Console, and given user has also them available” error is printed in Rublon MFA for RD Gateway’s log file in the following scenarios:
• The methods listed in authenticationMethods in the Windows Registry are not enabled in the Rublon Admin Console. For example, authenticationMethods is defined as push,email, while an application of type Remote Desktop Gateway defined in the Applications tab of the Rublon Admin Console has been assigned a custom policy that deactivates these two authentication methods.
• None of the methods defined in authenticationMethods is enrolled with a given user’s account.
Resolution
1. Sign in to the Rublon Admin Console.
2. Verify that the authentication methods defined in authenticationMethods are enabled in an application of type Remote Desktop Gateway defined in the Applications tab of the Rublon Admin Console. Pay attention to assigned policies.
3. Ensure that each affected user has at least one of these methods enrolled. If a user has not enrolled any of the methods defined in authenticationMethods, they will not be able to log in. In this case, send them an Enrollment Email along with instructions on how to enroll authenticators.
Best Practices
• Always keep the Admin Console configuration consistent with the registry settings.
• Always check the user enrollment status when troubleshooting login issues.
Helpful Links
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